Настройка vPC (Virtual Port-Channel) коммутатора

Ниже приведен скрипт для настройки vPC коммутатора. Если таких коммутаторов будет несколько, необходимо использовать скрипт для каждого из них.

!Добавляем VLAN1002, где будет ходить трафик изолированных сетей
!
vlan 1002
  name vstack-vm1002
!
!Настройка HSRP интерфейса
!
interface Vlan2000
  description "Vstack-routed"
  no shutdown
  no ip redirects
  ip address 172.20.0.253/24
  no ipv6 redirects
  hsrp version 2
  hsrp 2
    preempt
    priority 255
    ip 172.20.0.1
!
!Настройка p2p адресации интерфейса mgmt0 для keep-alive
!
interface mgmt0
  vrf member management
  ip address 10.0.0.1/30
!
!Настройка домена vPC
!
vpc domain 1
  role priority 10
  peer-keepalive destination 10.0.0.2 source 10.0.0.1
  delay restore 150
  peer-gateway
  layer3 peer-router
  auto-recovery
  ip arp synchronize
!
!Настройка IGMP querier для изолированных сетей vStack
!  
vlan configuration 2000
  ip igmp snooping querier 172.20.0.253
!
!Настройка интерфейса-агрегата peer-link 
!
interface port-channel100
 description [Po100] vPC peer-link
  switchport mode trunk
  spanning-tree port type network
  vpc peer-link
!
!Типовая настройка port-channel интерфейса для подключения хоста
!
interface port-channel15
  description vStack host
  switchport mode trunk
  spanning-tree port type edge trunk
  mtu 9216
  vpc 15

Настройка маршрутизатора

Также необходимо произвести настройку маршрутизатора. Ниже приведен скрипт для настройки.

!Объединяем интерфейсы в агрегат
!
interface TenGigE0/0/2/2
bundle id 1 mode active
transceiver permit pid all
!
interface TenGigE0/0/2/3
bundle id 1 mode active
transceiver permit pid all
 
!
!Создаем виртуальный интерфейс-агрегат
!
interface Bundle-Ether1
!
!Делим его на субинтерфейсы
!
interface Bundle-Ether1.2005
description Downlink to Vstack  vlan 2005 net  1.2.3.0/24
ipv4 address 1.2.3.253 255.255.255.0
encapsulation dot1q 2005
!
!Настраиваем HSRP
!
router hsrp
interface Bundle-Ether1.2005
  address-family ipv4
  hsrp 2005
  address 1.2.3.1